# Fehlermeldung “HTTP-Status 502: Bad Gateway” in ARR-IIS-Farm

**URL:** <https://entwicklergate.de/t/fehlermeldung-http-status-502-bad-gateway-in-arr-iis-farm/415>\
**Category:** Administration\
**Tags:** iis, arr\
**Created:** [16. Dezember 2019 um 09:21 UTC](https://entwicklergate.de/t/fehlermeldung-http-status-502-bad-gateway-in-arr-iis-farm/415 "2019-12-16T09:21:48Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![UweKeim](https://entwicklergate.de/user_avatar/entwicklergate.de/uwekeim/32/432_2.png) [@UweKeim](https://entwicklergate.de/u/UweKeim)\
**Post date:** [16. Dezember 2019 um 09:21 UTC](https://entwicklergate.de/t/fehlermeldung-http-status-502-bad-gateway-in-arr-iis-farm/415/1 "2019-12-16T09:21:48Z")

</div>

In einer IIS-Farm, die mit [Application Request Routing (ARR)](https://www.iis.net/downloads/microsoft/application-request-routing) aufgebaut ist, kommt beim HTTP-POST und anschließendem Verbeiten von Business-Logik auf dem Zielserver folgende Fehlermeldung zurück:

> HTTP-Status 502: Bad Gateway

Ursache ist, dass ein Skript auf einem Farm-Server zu lange läuft, und der ARR-Server in ein Timeout läuft.

### Lösung

Auf Befehlszeile (CMD) folgendes eingeben:

1. `cd C:\Windows\SysWOW64\inetsrv`
2. `appcmd.exe set config -section:webFarms /[name='meine-farm'].applicationRequestRouting.protocol.timeout:"00:10:45" /commit:apphost`
3. Zur Sicherheit noch `iisreset` durchführen

(`meine-farm` ist der Name der Farm, so wie sie im IIS-Manager angezeigt wird)

Anschließend war bei mir der Fehler weg.

[Dieser MSDN-Blog-Artikel](https://blogs.iis.net/richma/502-3-bad-gateway-the-operation-timed-out-with-iis-application-request-routing-arr) hat mir mit der Lösung geholfen.
