ERR_SSL_PROTOCOL_ERROR beim Starten von ASP.NET-Webanwendungen

Verhalten

Immer mal wieder erhalte ich beim Debuggen/Starten von Webanwendungen in Visual Studio 2019 im Browser eine Fehlermeldung:

Diese Website kann keine sichere Verbindung bereitstellen

localhost hat eine ungültige Antwort gesendet.

Versuchen Sie, die Windows-Netzwerkdiagnose auszuführen.

ERR_SSL_PROTOCOL_ERROR

Mir ist dann aufgefallen, dass die URL immer automatisch von HTTP nach HTTPS umgeleitet wird.

In anderen Browsern passiert das nicht, nur in Google Chrome.

Ursache

Google Chrome leitet wohl automatisch in manchen Fällen um.

Hier ist es genauer beschrieben:

Lösung

Die hier beschriebene Lösung hat funktioniert:

  1. Go to chrome://net-internals/#hsts. Enter „localhost“ under Delete domain security policies and press the Delete button.

  2. Now go to chrome://settings/clearBrowserData, tick the box Cached images and files and press click the button Clear data.

Anschließend hat das wieder korrekt funktioniert, ich musste nicht mal den Browser neu starten.

Ich musste das immer wieder mal machen, keine Ahnung, ob das ein Bug ist, oder Absicht.